Pat【甲级】 1004 Counting Leaves(附中文题目)

Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

中文题目

家庭关系可以用家谱树来表示,给定一个家谱树,你的任务是找出其中没有孩子的成员。

输入格式
第一行包含一个整数 N 表示树中结点总数以及一个整数 M 表示非叶子结点数。

接下来 M 行,每行的格式为:

ID K ID[1] ID[2] ... ID[K]

ID 是一个两位数字,表示一个非叶子结点编号,K 是一个整数,表示它的子结点数,接下来的 K 个 ID[i] 也是两位数字,表示一个子结点的编号。
为了简单起见,我们将根结点固定设为 01。
所有结点的编号即为 01,02,03,…,31,32,33,…,N。

输出格式
输出从根结点开始,自上到下,树的每一层级分别包含多少个叶子节点。

输出占一行,整数之间用空格隔开。

数据范围
0<N<100
输入样例:

2 1
01 1 02

输出样例:

0 1

样例解释
该样例表示一棵只有 2 个结点的树,其中 01 结点是根,而 02 结点是其唯一的子节点。
因此,在根这一层级上,存在 0 个叶结点;在下一个级别上,有 1 个叶结点。
所以,我们应该在一行中输出0 1。


分析:首先我们要明白题目的意思是求每个层的叶子节点(没有子节点),那么我们需要去构建出父节点和子节点的关系(在这是利用vector来存储),再一个就是要去计算出最大深度,这样就结束了。

代码

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
const int N = 110;
int n, m;
vector<int>vv[N];
int r_depth[N];
int max_depth;
void dfs(int u,int depth) {
	max_depth = max(max_depth, depth);  //更新最大深度
	//判断该结点是否是叶子结点
	if (vv[u].size() == 0) {
		r_depth[depth]++;
		return;
	}
	for (int i = 0; i < vv[u].size(); i++) {
		dfs(vv[u][i], depth + 1);
	}
}
int main() {
	cin >> n >> m;
	for (int i = 0; i < m; i++) {
		int a,num;
		cin >> a >> num;
		for (int j = 0; j < num; j++) {
			int b;
			cin >> b;
			vv[a].push_back(b);
		}
	}
	dfs(1,0);
	for (int i = 0; i <=max_depth; i++) {
		cout << r_depth[i] << " ";
	}
	cout << endl;
	return 0;
}

运行结果

在这里插入图片描述

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值