ZOJ Problem Set - 2110 Tempter of the Bone

ZOJ Problem Set - 2110
Tempter of the Bone

Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

The doggie found a bone in an ancient maze, which fascinated him a lot. However,   when he picked it up, the maze began to shake, and the doggie could feel the   ground sinking. He realized that the bone was a trap, and he tried desperately   to get out of this maze.

  The maze was a rectangle with sizes N by M. There was a door in the maze. At   the beginning, the door was closed and it would open at the T-th second for   a short period of time (less than 1 second). Therefore the doggie had to arrive   at the door on exactly the T-th second. In every second, he could move one block   to one of the upper, lower, left and right neighboring blocks. Once he entered   a block, the ground of this block would start to sink and disappear in the next   second. He could not stay at one block for more than one second, nor could he   move into a visited block. Can the poor doggie survive? Please help him.


Input

  The input consists of multiple test cases. The first line of each test case   contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50),   which denote the sizes of the maze and the time at which the door will open,   respectively. The next N lines give the maze layout, with each line containing   M characters. A character is one of the following:

  'X': a block of wall, which the doggie cannot enter;
  'S': the start point of the doggie;
  'D': the Door; or
  '.': an empty block.

  The input is terminated with three 0's. This test case is not to be processed.


Output

  For each test case, print in one line "YES" if the doggie can survive,   or "NO" otherwise.


Sample Input

  4 4 5
  S.X.
  ..X.
  ..XD
  ....
  3 4 5
  S.X.
  ..X.
  ...D
  0 0 0


  Sample Output


  NO
  YES

不减少递归条件就会TLE,使劲了各种手段、查题解,修改递归函数,调试了半天才过了。。。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char maze[10][10];
int si,sj,ei,ej;
int n,m,t;
int flag;
int dir[4][2]={{0,-1},{0,1},{-1,0},{1,0}};
int abs(int num)
{
	if(num<0)return -1*num;
	else return num;
}
void dfs(int i,int j,int ct)
{
	if(i<=0||i>n||j<=0||j>m)
	{
		return ;
	}
	else if(ct>t)return;
	else if(i==ei&&j==ej&&ct==t)
	{ 
		//cout<<"========in 'D'======"<<endl;
		//cout<<"i: "<<i<<" j: "<<j<<" ct: "<<ct<<endl;
		//cout<<maze[i][j]<<endl;
		//cout<<"========in 'D'======"<<endl;
	    flag=true;
		return;
	}
	int temp=(t-ct)-abs(i-ei)-abs(j-ej);//减少递归分支,以免超时 
	//cout<<"temp: "<<temp<<endl;
	if(temp<0||temp%2)return;
    for(int k=0;k<4;k++)
    {
    	//cout<<"k: "<<k<<endl;
    	if(maze[i+dir[k][0]][j+dir[k][1]]=='.')//检查周围的点是否是一个点    	{
    		//cout<<"i: "<<i<<" j: "<<j<<" ct: "<<ct<<endl; 
    		maze[i+dir[k][0]][j+dir[k][1]]='X';
    		dfs(i+dir[k][0],j+dir[k][1],ct+1);
			maze[i+dir[k][0]][j+dir[k][1]]='.';
    		if(flag)return;
    		
    	}
    }
	
}
int main()
{
	while(cin>>n>>m>>t)
	{
		if(n==0&&m==0&&t==0)break;
		memset(maze,0,sizeof(maze));
	    //memset(visit,0,sizeof(maze));
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				cin>>maze[i][j];
				if(maze[i][j]=='S')
				{
					si=i;sj=j;
					maze[i][j]='X';
				}
				else if(maze[i][j]=='D')
				{
					ei=i;ej=j;
					maze[i][j]='.';
				}
			}
		}
		flag=false;
		dfs(si,sj,0);
		if(flag)
		{
			cout<<"YES"<<endl;
		}
		else cout<<"NO"<<endl;
	}
} 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值