Description
Now we have a number, you can swap any two adjacent digits of it, but you can not swap more than K times. Then, what is the largest probable number that we can get after your swapping?
Input
There is an integer T (1 <= T <= 200) in the first line, means there are T test cases in total.
For each test case, there is an integer K (0 <= K < 106) in the first line, which has the same meaning as above. And the number is in the next line. It has at most 1000 digits, and will not start with 0.
There are at most 10 test cases that satisfy the number of digits is larger than 100.
Output
For each test case, you should print the largest probable number that we can get after your swapping.
Sample Input
3 2 1234 4 1234 1 4321
Sample Output
3124 4213 4321
思路:贪心
首先尽量把最高位变成最大的数字,再往右一位位一样的操作,直到变换次数用完
代码如下:
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
int T, s, len;
char ch[1001];
cin >> T;
while(T--)
{
cin >> s >> ch;
len = strlen(ch);
for (int i = 0; i < len; i++)
{
if (s <= 0)break;
char max = '0';
int key;
for (int j = i + 1; j < len && j <= i + s; j++){
if (max < ch[j]){
max = ch[j];
key = j;
}
}
if (max > ch[i])
{
for (int j = key; j > i; j--){
ch[j] = ch[j - 1];
}
ch[i] = max, s -= key - i;
}
}
cout << ch << endl;
}
return 0;
}