菜鸡敲得快速幂(自用)

我是菜鸡菜鸡菜鸡自用

三个数a,b,c(1<a,b,c<1e18)
a^b%c

样例输入
2 3 5

样例输出
3

装13版本

import java.util.Scanner;
public class Main {
 public static void main(String[] args) {  
   Scanner sc = new Scanner(System.in);
   long a = sc.nextLong();
   long b = sc.nextLong();
   long c = sc.nextLong();
   
   long ans = 1L;
   a = a%c;
   while(b!=0) {
    if((b&1)==1)  ans = (ans*a)%c;
    a = (a*a)%c;
    b >>= 1;
   }
   System.out.println(ans);
 }
}

菜鸡新手版本

import java.util.Scanner;
public class Main {
 public static void main(String[] args) {  
   Scanner sc = new Scanner(System.in);
   long a = sc.nextLong();
   long b = sc.nextLong();
   long c = sc.nextLong();
   
   long ans = 1L;
   a = a%c;
   while(b!=0) {
    if(b%2==1)  ans = (ans*a)%c;
    a = (a*a)%c;
    b = b/2;
   }
   System.out.println(ans);
 }
}

试了试第一种更快,第二种略慢

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值