hdu2845

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5154    Accepted Submission(s): 2392


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
  
  
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 

Sample Output
  
  
242

先得到每一行的最大值,在同理得到每列的最大值

代码的注释更加详细:

#include <bits/stdc++.h> 
using namespace std;  
const int MAX=200005;  
int dpx[MAX],dpy[MAX];   
int main(int argc,char *argv[])
{
//	freopen("data.in.txt","r",stdin);	
    int row,col;  
    while(~scanf("%d%d",&row,&col)){  
        for(int i=2;i<=row+1;i++){  
            for(int j=2;j<=col+1;++j){
			    int n;
                scanf("%d",&n);  
                dpx[j]=max(dpx[j-1],dpx[j-2]+n);//表示一行中第j个元素的dp值可以直接等于第j-1个元素的值或者第j-2个元素的值加上n,因为
												//题意说明了一行的某个元素不能直接由左右两个元素加上该元素的权值得到  
            }  
            dpy[i]=max(dpy[i-1],dpy[i-2]+dpx[col+1]);//同理,此处的dpx[row+1]就是该行的dp值  
        }  
        cout<<dpy[row+1]<<endl;  
    }  
    return 0;  
}   


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值