poj3278 抓牛(bfs)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

该题主要需要判断状态,每个点的状态不仅有坐标,还有下一步该走的方式(向前,向后,跳一步),所以使用vis数组来记录;

#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
const int maxn=1000000;
int vis[maxn][3];
int n,k;
struct node
{
	int x;
	int step;
};
int bfs()
{
	queue<node>q;
	node nxt,pre;
	pre.x=n,pre.step=0;
	q.push(pre);
	while(!q.empty()){
		pre=q.front();
		q.pop();
		if(pre.x==k){
			return pre.step;
		}
		for(int i=0;i<3;i++){
//			int tempx;
			if(i==0){
				nxt.x=pre.x-1;
				nxt.step=pre.step+1;
				if(!vis[nxt.x][0]&&nxt.x>=0&&nxt.x<4*100000){	
					q.push(nxt);
					vis[nxt.x][0]=1;
				}
			}
			if(i==1){
				nxt.x=pre.x+1;
				nxt.step=pre.step+1;
				if(!vis[nxt.x][1]&&nxt.x>=0&&nxt.x<4*100000){	
					q.push(nxt);
					vis[nxt.x][1]=1;
				}
			}
			if(i==2){
				nxt.x=2*pre.x;
				nxt.step=pre.step+1;
				if(!vis[nxt.x][2]&&nxt.x>=0&&nxt.x<4*100000){	
					q.push(nxt);
					vis[nxt.x][2]=1;
				}
			}
		}
	}
	return -1;
}
int main()
{
	ios::sync_with_stdio(false);
	while(cin>>n>>k){
		memset(vis,0,sizeof vis);
		cout<<bfs()<<endl;
	}
	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值