hdoj 1242 Rescue

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M. Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13


做题感言

简单的BFS题但却做了那么长时间,哎,不过终于弄会了。和最少步数的题差不多,把基本的弄明白,应该就会了



#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char map[201][201];
int m,n,vis[201][201];
int d[4][2]={0,1,-1,0,1,0,0,-1};
struct node
{
	int x,y,step;
	friend bool operator < (const node &a,const node &b) 
    {
       	return a.step>b.step;
	}   
}a,temp;
int juge(struct node a)
{
	if(a.x<0||a.x>=m)
		return 0;
	if(a.y<0||a.y>=n)
		return 0;
	if(vis[a.x][a.y]||map[a.x][a.y]=='#')
		return 0;
	return 1;	
}
int bfs(int x,int y)
{
	priority_queue<node>q;
	memset(vis,0,sizeof(vis));
	a.x=x;
	a.y=y;
	a.step=0;
	vis[x][y]=1;
	q.push(a);
	while(!q.empty())
	{
		a=q.top();
		q.pop();
		if(map[a.x][a.y]=='r')
			return a.step;
		for(int i=0;i<4;i++)
		{
				temp.x=a.x+d[i][0];
				temp.y=a.y+d[i][1];
				
			if(juge(temp))
			{
				vis[temp.x][temp.y]=1;
				if(map[temp.x][temp.y]=='x')
					temp.step=a.step+2;
				else
					temp.step=a.step+1;	
				q.push(temp);
			}
		}
	}
	return -1;	
}
int main()
{
	int i,j,x,y,ans;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		for(i=0;i<m;i++)
		{
			scanf("%s",&map[i]);
			for(j=0;j<n;j++)		
				if(map[i][j]=='a')
				{
					x=i;
					y=j;
				}	
		}
	ans=bfs(x,y);
	if(ans==-1)
		printf("Poor ANGEL has to stay in the prison all his life.\n");
	else
		printf("%d\n",ans);	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值