hdu 1035 robot motion

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10533    Accepted Submission(s): 4940


Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
 

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
 

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
 

Sample Input
  
  
3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
 

Sample Output
  
  
10 step(s) to exit 3 step(s) before a loop of 8 step(s)

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

一次AC了哈哈哈哈,:D


首先就是确定要用DFS,走的步数c不断+1,如果越界的话,停止,反弹

第一种情况:

能走出来,没有死循环。那么就输出走的步数C。

第二种情况:

陷入死循环。要输出没陷入循环之前走的步数X,和循环走的步数Y。

设置一个访问数组vi【15】【15】。初始值设为0。走过一次vi++。循环走两圈。

这样不是循环的地方,vi为1,是循环的地方,vi为2.

当第三圈走循环的时候,遇到vi==2的地方,就return返回。

这样,遍历数组vi,x,y分别计数vi==1和vi==2,即为正常的步数和陷入循环的步数。


#include <iostream>
#include <cstring>
using namespace std;
int n,m,c;
char a[15][15];
int vi[15][15];
int flag;
void dfs(int nn,int mm,int c)
{
	if(nn>n||mm<1||mm>m||nn<1) {printf("%d step(s) to exit",c);return;}
	else if(vi[nn][mm]==0||vi[nn][mm]==1) vi[nn][mm]++;
	else if(vi[nn][mm]==2)
	{	int x=0,y=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if(vi[i][j]==1)x++;
				else if(vi[i][j]==2)y++;
			}
		}	
		printf("%d step(s) before a loop of %d step(s)",x,y);return;
	}
	switch(a[nn][mm])
	{
		case 'N':{nn-=1;dfs(nn,mm,c+=1);break;}
		case 'S':{nn+=1;dfs(nn,mm,c+=1);break;}
		case 'W':{mm-=1;dfs(nn,mm,c+=1);break;}
		case 'E':{mm+=1;dfs(nn,mm,c+=1);break;}
	}
}

int main()
{
	int s;
	while(cin>>n>>m>>s&&n&&m&&s)
	{
		memset(vi,0,sizeof(vi));
		for(int i=1;i<=n;i++)
			for(int j=1;j<=m;j++)
				cin>>a[i][j];
		flag=0;
		dfs(1,s,0);
		cout<<endl;
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值