POJ 2739 素数打表-----水题

http://poj.org/problem?id=2739

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime  
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.  
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

一开始拿到题目没有思路,后来,想到打表,之前写了一次,错了,重新写。感觉自己不是很自信,打表怕超时,其实素数没多多少的。题目没有给范围,不要怕,做一下应该能出来的。打完表,判断下,小于的继续加,等于的就+1,大于直接下一个。

#include<iostream>
using namespace std;
int main()
{
	int a[10000];
	a[0] = 2;
	int num = 1;
	for (int i = 3; i < 10000; i++)
	{
		int flag = 0;
		for (int j = 2; j < i; j++)
		{
			if (i%j == 0)
			{
				flag = 1;
				break;
			}
		}
		if (flag == 0)
		{
			a[num] = i;
			num++;
		}
	}
	int n;
	while (cin >> n)
	{
		if (n == 0)
			break;
		int sum = 0,Num=0;
		for (int i = 0; i < num; i++)
		{
			sum = a[i];
			for (int j = i+1;; j++)
			{
				if (sum == n)
				{
					Num++;
					break;
				}
				else if (sum>n)
				{
					break;
				}
				else if (sum < n)
				{
					sum += a[j];
				}
			}
		}
		cout << Num << endl;
	}
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值