Goldbach`s Conjecture LightOJ - 1259 Runtime Error

Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

  1.  Both a and b are prime
    
  2.  a + b = n
    
  3.  a ≤ b
    

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Note

An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …

线性筛数组不能开到1e7!!!!!!

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int t;
const int N=10000001;
bool vis[N];
int p[N/10];//线性筛数组不能开到1e7
void primes()
{
    memset(vis,false,sizeof(vis));
    t=0;
    for(long long int i=2; i<=N; i++)
    {
        if(!vis[i]) p[t++]=i;
        for(long long int j=0; j<t&&i*p[j]<=N; j++)
        {
            vis[i*p[j]]=true;
            if(i%p[j]==0)
                break;
        }
    }
}

int main()
{
    primes();
    int k;
    cin>>k;
    vis[0]=vis[1]=1;
    for(int x=1; x<=k; x++)
    {
        int n;
        cin>>n;
        printf("Case %d: ",x);
        int countt=0;
        for(int a=0; p[a]<=n/2; a++)
        {
            if(!vis[n-p[a]])
            {
                countt++;
            }
        }
        cout<<countt<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JdiLfc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值