Can you answer these queries?(超时问题)--线段树

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6
题目大意:给一个n,然后是n个数,第i个数代表编号为i的武器的当前耐久度,每次武器使用都会使耐久度变成原来的平方根,然后输入m,代表m个操作,输入k,x,y,如果k=0,代表武器从编号x到y使用,为1则输出x到y的武器的耐久度的和
TLE原因主要有:

  1. 数组开小了
  2. n,m没有long long
  3. 线段树递归的时候跑了好多无用的!!!
#include<iostream>
#include<math.h>
#include<stdio.h>
using namespace std;
const int N=100009;
#define ll long long
ll n,m;
long long a[N];
long long sum[N<<2];
// Segment tree
//把更新的函数去掉了,直接放在里面
void tree_build(ll rt,ll l,ll r)
{
    if(l==r)
    {
        sum[rt]=a[l];
        return ;
    }
    ll mid=(l+r)>>1;
    tree_build(rt<<1,l,mid);
    tree_build(rt<<1|1,mid+1,r);
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void revise(ll L,ll R,ll l,ll r,ll rt)
{
    if(l>R||r<L||sum[rt]==(r-l+1)) return;//这一行!!!
    if(l==r)
    {
        sum[rt]=(long long)sqrt(sum[rt]);
        return ;
    }
    ll mid=(r+l)>>1;
    if(L<=mid) revise(L,R,l,mid,rt<<1);
    if(R>mid) revise(L,R,mid+1,r,rt<<1|1);
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
long long query(ll L,ll R,ll l,ll r,ll rt)
{
    if(l>R||r<L) return 0;
    if(L<=l&&r<=R) return sum[rt];
    long long res=0;
    ll mid=(l+r)>>1;
    if(L<=mid) res+=query(L,R,l,mid,rt<<1);
    if(R>mid) res+=query(L,R,mid+1,r,rt<<1|1);
    return res;
}
int main()
{
    ll k=1;
    while(~scanf("%lld",&n))
    {
        for(ll i=1; i<=n; i++) scanf("%lld",&a[i]);
        tree_build(1,1,n);
        scanf("%lld",&m);
        printf("Case #%lld:\n",k++);
        while(m--)
        {
            ll k,x,y;
            scanf("%lld%lld%lld",&k,&x,&y);
            if(x>y) swap(x,y);
            if(k==0)
                revise(x,y,1,n,1);
            else
                printf("%lld\n",query(x,y,1,n,1));
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JdiLfc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值