[PAT] A1012 The Best Rank


To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

Code

之前一直没注重算法题练习, ,代码写出来的怕是几天之后自己都看不懂了。
依然是一道结构体处理的题,应该也是可以使用map的,还没习惯使用,回过头重新用map写吧。
结构体这个版本处理的太麻烦了,对A , C , M , E四个成绩分别进行了排序,并赋值ra , rc , rm , re
针对每一次查询,如果一个人存在并列排名要按照优先级为A , C , M , E的顺序输出。如果查询的id不存在,则直接输出N/A
需要注意存在4分的测试点,对不同学生存在相同成绩的排序,成绩相同的名次是相同的。

eg:
`in`:                        `out`:
310101 95                       1
310102 90                       3
310103 95                       1
310104 85                       5
310105 90                       3

AC Code:

#include<bits/stdc++.h>
using namespace std;

struct person
{
    string id;
    int c,m,e,a;
    int rc,rm,re,ra;
}p[3010];

bool cmp1(person x,person y)
{
    return x.a>y.a;
}
bool cmp2(person x,person y)
{
    return x.c>y.c;
}
bool cmp3(person x,person y)
{
    return x.m>y.m;
}bool cmp4(person x,person y)
{
    return x.e>y.e;
}
int main()
{
    int n,m;
    string s;
    cin>>n>>m;
    for(int i=0;i<n;i++)
        cin>>p[i].id>>p[i].c>>p[i].m>>p[i].e;
    for(int i=0;i<n;i++)
        p[i].a=((p[i].c+p[i].m+p[i].e)/3);
    sort(p,p+n,cmp1);
    for(int i=0;i<n;i++)
    {
        if(!i || (i && p[i].a<p[i-1].a))
            p[i].ra = i+1;
        else if(i && p[i].a == p[i-1].a)
            p[i].ra = p[i-1].ra;
    }
    sort(p,p+n,cmp2);
    for(int i=0;i<n;i++)
    {
        if(!i || (i && p[i].c<p[i-1].c))
            p[i].rc = i+1;
        else if(i && p[i].c == p[i-1].c)
            p[i].rc = p[i-1].rc;

    }
    sort(p,p+n,cmp3);
    for(int i=0;i<n;i++)
    {
        if(!i || (i && p[i].m<p[i-1].m))
            p[i].rm = i+1;
        else if(i && p[i].m == p[i-1].m)
            p[i].rm = p[i-1].rm;
    }
    sort(p,p+n,cmp4);
    for(int i=0;i<n;i++)
    {
        if(!i || (i && p[i].e<p[i-1].e))
            p[i].re = i+1;
        else if(i && p[i].e == p[i-1].e)
            p[i].re = p[i-1].re;
    }
    for(int i=0;i<m;i++)

    {
        cin>>s;
        int flag=1;
        int arr[4]={0},temp[4]={0};
        for(int j=0;j<n;j++)
        {
            if(s == p[j].id)
            {
                flag=0;
                temp[0]=p[j].ra,temp[1]=p[j].rc,temp[2]=p[j].rm,temp[3]=p[j].re;
                sort(temp,temp+4);
                if(p[j].ra == temp[0])
                    cout<<p[j].ra<<" A"<<endl;
                else if(p[j].rc == temp[0])
                    cout<<p[j].rc<<" C"<<endl;
                else if(p[j].rm == temp[0])
                    cout<<p[j].rm<<" M"<<endl;
                else if(p[j].re == temp[0])
                    cout<<p[j].re<<" E"<<endl;
            }
        }
        if(flag)
            cout<<"N/A"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值