hdu1158 Employment Planning

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5151    Accepted Submission(s): 2208


Problem Description
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
 

Input
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
 

Output
The output contains one line. The minimal total cost of the project.
 

Sample Input
  
  
3 4 5 6 10 9 11 0
 

Sample Output
  
  
199
 





本题的意思是给出给出雇佣一个工人的钱,工人每月的钱,和解雇工人的钱,和每月所需工人,算出最小花费。

想法就是把每月雇佣多少个工人的费用全保存下来,for跑一遍找出得到上月雇佣j个到本月的雇佣k个工人所需的最小花费,第一个月特殊处理

这题没给每月工人个数,我那100做过了



代码如下






#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f

int dp[15][110];
int e,f,s;
int a[15];

int main()
{
    int n;
    int mn;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d%d%d",&e,&s,&f);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0; i<110; i++)
        {
            dp[1][i]=(e+s)*i;
        }
        for(int i=2;i<=n;i++)
        {
            for(int j=a[i];j<110;j++)//本月至少要a[i]个人
            {
                mn=inf;
                for(int k=a[i-1];k<110;k++)//上月必须要到a[i-1]个人才符合
                {
                         if(k<=j)
                    mn=min(mn,dp[i-1][k]+k*s+(j-k)*(s+e));//人增多,多雇佣
                    else
                        mn=min(mn,dp[i-1][k]+j*s+(k-j)*f);//人减少,解雇
                }
                dp[i][j]=mn;
            }
        }
        mn=inf;
        for(int i=a[n];i<110;i++)
        {
            mn=min(mn,dp[n][i]);
        }
        printf("%d\n",mn);

    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值