HDU1349 Minimum Inversion Number

B - Minimum Inversion Number
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 

Output

For each case, output the minimum inversion number on a single line. 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

本题的意思是求逆序数,可以将前m个数放到序列最后面,求逆序数的最小值
方法就是找出每个数之前有多少个比它大的数累加即可,处理时可以用树状数组,也可以用线段树,我用的是线段树
先建一棵空树,依次处理每个元素,把线段树的对应节点a[i]++,然后在原序列中,在a[i]前面且比它大的就是在线段树中
a[i+1]到n这段区间和了;
这样容易找原序列的逆序数,至于调动是有个规律的,每次把第一个移到后面,逆序数就等于原来的-(后面比a小的)+(比a大的)
 
    
 
    
 
    
 
    
代码如下
 
    
 
    
 
    
 
    
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f

int a[5005];
int tree[5005*4];

void build(int n,int l,int r)
{
    if(l==r)
    {
        tree[n]=0;
        return;
    }
    int m=(l+r)>>1;
    build(n<<1,l,m);
    build(n<<1|1,m+1,r);
    tree[n]=tree[n<<1]+tree[n<<1|1];
}


void update(int n,int l,int r,int pos)
{
    if(l==r)
    {
        tree[n]++;
        return;
    }
    int m=(l+r)>>1;
    if(pos<=m)
        update(n<<1,l,m,pos);
    else
        update(n<<1|1,m+1,r,pos);
    tree[n]=tree[n<<1]+tree[n<<1|1];
}

int query(int n,int l,int r,int ll,int rr)
{
    if(ll<=l&&rr>=r)
    {
        return tree[n];
    }

    int ans=0;
    int m=(l+r)>>1;
    if(ll<=m)
        ans+=query(n<<1,l,m,ll,rr);
    if(rr>m)
        ans+=query(n<<1|1,m+1,r,ll,rr);
    return ans;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            a[i]++;
        }
        build(1,1,n);
        int cnt=0;
        for(int i=1; i<=n; i++)
        {
            update(1,1,n,a[i]);
            cnt+=query(1,1,n,a[i]+1,n);
        }

        int mx=cnt;
        for(int i=1; i<=n; i++)
        {
            cnt=cnt-(a[i]-1)+(n-a[i]);
            mx=min(mx,cnt);
        }
        printf("%d\n",mx);
    }
    return 0;
}


 
    
 
    
 
    
 
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值