Hdu1051 Wooden Sticks

22 篇文章 0 订阅

Wooden Sticks



Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source

 

————————————————————————————————————

题目的意思是给出若干个物品的长度和质量,调整机器需要1分钟,加工时如果下一件物品质量和长度都比上一件大或相等,那么不用重新调整,否则重新调整,问最少时间

思路:贪心,按长度或质量从小到大排序,依次取,找出递增子序列个数


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <string>
#include <set>
#include<vector>
#include <map>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long

struct node{
int a,b,flag;
}p[100005];

bool cmp(node x,node y)
{
    if(x.a!=y.a)
    return x.a<y.a;
    return x.b<y.b;
}

int main()
{
    int n;
    int T;
    scanf("%d",&T);
    while(T--)
    {scanf("%d",&n);
        memset(p,0,sizeof p);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].a,&p[i].b);
        }
        sort(p,p+n,cmp);
        int cnt=0;
        while(1)
        {
            int fl=0;
            int ma,mb;
            for(int i=0;i<n;i++)
            {
                if(p[i].flag==0)
                {
                    if(fl==0)
                    {
                        ma=p[i].a;
                        mb=p[i].b;
                        p[i].flag=1;
                        fl=1;
                    }
                    else
                    {
                        if(p[i].a>=ma&&p[i].b>=mb)
                        {
                            ma=p[i].a;
                            mb=p[i].b;
                            p[i].flag=1;
                        }
                    }
                }
            }
            if(fl==0)
                break;
            cnt++;

        }
        printf("%d\n",cnt);
    }

    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值