L1-023. 输出GPLT
时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT....”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:pcTclnGloRgLrtLhgljkLhGFauPewSKgt输出样例:
GPLTGPLTGLTGLGLL
——————————————————————————————————————
开4个变量分别记录GPLT个数(不分大小写),按序输出即可
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <queue>
#include <map>
using namespace std;
#define inf 0x3f3f3f3f
int main()
{
int a=0,b=0,c=0,d=0;
char s[100004];
scanf("%s",s);
int k=strlen(s);
for(int i=0; i<k; i++)
{
if(s[i]=='g'||s[i]=='G')
a++;
else if(s[i]=='p'||s[i]=='P')
b++;
else if(s[i]=='l'||s[i]=='L')
c++;
else if(s[i]=='t'||s[i]=='T')
d++;
}
while(a>0||b>0||c>0||d>0)
{
if(a>0)
{
printf("G");
a--;
}
if(b>0)
{
printf("P");
b--;
}
if(c>0)
{
printf("L");
c--;
}
if(d>0)
{
printf("T");
d--;
}
}
printf("\n");
return 0;
}