POJ3026 Borg Maze

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14165 Accepted: 4619

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

Source

—————————————————————————————————————
题意:在一个迷宫里,起点是S,A代表外星人,我们需要找到最短的路径将S和所有的A连接起来,输出最短的这个路径总长
思路:先bfs建图,再最小生成树处理

注意:测试数据多了莫名其妙的空格,getchar()会wa,看了discuss在知道,智商题浪费时间

#include <iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<set>
#include<cstring>
using namespace std;
#define LL long long

struct node
{
    int u,v,w;
} p[1000005];

struct point
{
    int x,y,t;
};

char mp[105][105];
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};
int vis[105][105];

int n,m,cnt,tot,pre[10005];

bool cmp(node a,node b)
{
    return a.w<b.w;
}
void init()
{
    for(int i=0; i<10005; i++)
        pre[i]=i;
}

int fin(int x)
{
    return pre[x]==x?x:pre[x]=fin(pre[x]);
}

void kruskal()
{
    sort(p,p+cnt,cmp);
    init();
    int cost=0;
    int ans=0;
    for(int i=0; i<cnt; i++)
    {
        int a=fin(p[i].u);
        int b=fin(p[i].v);
        if(a!=b)
        {
            pre[a]=b;
            cost+=p[i].w;
            ans++;
        }
        if(ans==tot-1)
        {
            break;
        }
    }
    printf("%d\n",cost);
}

bool check(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m||mp[x][y]=='#')
        return 0;
    return 1;
}

void build(int x,int y)
{
    memset(vis,0,sizeof vis);
    point f,d;
    f.x=x;
    f.y=y;
    f.t=0;
    vis[x][y]=1;
    queue<point>q;
    q.push(f);
    while(!q.empty())
    {
        f=q.front();
        q.pop();
        if((mp[f.x][f.y]=='A'||mp[f.x][f.y]=='S')&&(f.x!=x||f.y!=y))
        {
            p[cnt].u=100*x+y;
            p[cnt].v=100*f.x+f.y;
            p[cnt++].w=f.t;
        }
        for(int i=0; i<4; i++)
        {
            int xx=f.x+dir[i][0];
            int yy=f.y+dir[i][1];
            if(!vis[xx][yy]&&check(xx,yy))
            {
                d.x=xx;
                d.y=yy;
                d.t=f.t+1;
                vis[xx][yy]=1;
                q.push(d);
            }
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        char temp[51];
        gets(temp);
        for(int i=0; i<n; i++)
            gets(mp[i]);
        cnt=0,tot=0;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                if(mp[i][j]=='A'||mp[i][j]=='S')
                    build(i,j),tot++;
        kruskal();
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值