HDU6205 Coprime Sequence

7 篇文章 0 订阅
2 篇文章 0 订阅

Coprime Sequence

                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
                                                                                     Total Submission(s): 16    Accepted Submission(s): 13


Problem Description
Do you know what is called ``Coprime Sequence''? That is a sequence consists of  n  positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
 

Input
The first line of the input contains an integer  T(1T10) , denoting the number of test cases.
In each test case, there is an integer  n(3n100000)  in the first line, denoting the number of integers in the sequence.
Then the following line consists of  n  integers  a1,a2,...,an(1ai109) , denoting the elements in the sequence.
 

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
 

Sample Input
  
  
3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8
 

Sample Output
  
  
1 2 2
 

Source
 

题意:一共n个数,去掉其中一个,问剩余n-1个数gcd的最大值

解题思路:rmq或者求前缀和后缀


求前缀和后缀代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int a[100005],x[100005],y[100005];

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
            
        x[0]=a[0];
        for(int i=1; i<n; i++)
            x[i]=gcd(x[i-1],a[i]);
            
        y[n-1]=a[n-1];
        for(int i=n-2; i>=0; i--)
            y[i]=gcd(y[i+1],a[i]);
        
        int ans=max(y[1],x[n-2]);
        for(int i=1; i<n-1; i++)
            ans=max(ans,gcd(x[i-1],y[i+1]));
        printf("%d\n",ans);
    }
    return 0;
}


RMQ:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int a[100006],n;
int dp[100006][20];

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

void init()
{
    for(int i=1;i<=n;i++) dp[i][0]=a[i];
    for(int i=1;(1<<i)<=n;i++)
        for(int j=1;j+(1<<i)-1<=n;j++)
            dp[j][i]=gcd(dp[j][i-1],dp[j+(1<<(i-1))][i-1]);

}

int query(int l,int r)
{
    int k=0;
    while(1<<(k+1)<=r-l+1) k++;
    return gcd(dp[l][k],dp[r-(1<<k)+1][k]);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        init();
        int ma=-1;
        for(int i=2;i<n;i++)
        {
            int k=query(1,i-1),kk=query(i+1,n);
            ma=max(ma,gcd(k,kk));
        }
        ma=max(ma,query(2,n));
        ma=max(ma,query(1,n-1));
        printf("%d\n",ma);
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值