Hdu2819 Swap

Swap

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3371    Accepted Submission(s): 1235
Special Judge


Problem Description
Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
 

Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
 

Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”. 
 

Sample Input
      
      
2 0 1 1 0 2 1 0 1 0
 

Sample Output
      
      
1 R 1 2 -1
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2818  2821  2817  2825  2824 
 

——————————————————————————————————

题目的意思是给一个01矩阵,随意交换行和列,问是否能使左上到右下的对角线变为全1

思路:先进行行列二分匹配,如果可以在根据匹配的关系进行列调整(只需调列或调行就可以了)

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>
using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
const int MAXN=1005;
int uN,vN;  //u,v数目
int g[MAXN][MAXN];
int linker[MAXN];
bool used[MAXN];
int link[MAXN];
struct node
{
    int u,v;
}ans[100005];
bool dfs(int u)
{
    int v;
    for(v=1; v<=vN; v++)
        if(g[u][v]&&!used[v])
        {
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    return false;
}

int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=1; u<=uN; u++)
    {
        memset(used,0,sizeof(used));
        if(dfs(u))  res++;
    }
    return res;
}

int main()
{
    int m,n,k,x,y,T;
   while(~scanf("%d",&n))
   {
       for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        scanf("%d",&g[i][j]);
        uN=vN=n;
       if(hungary()<n)
        printf("-1\n");
       else
       {
           int cnt=0;
           for(int i=1;i<=n;i++)
           {
               while(linker[i]!=i)
               {
                   ans[cnt].u=i,ans[cnt++].v=linker[i];
                   swap(linker[i],linker[linker[i]]);
               }
           }
           printf("%d\n",cnt);
           for(int i=0;i<cnt;i++)
           {
               printf("C %d %d\n",ans[i].u,ans[i].v);
           }

       }
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值