PAT甲级 1121. Damn Single (25)

1121. Damn Single (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
——————————————————————————————————

题目的意思是先给出n组数,每组的两个数表示一对在查询每个人,如果一个人没对象或者他对象不再查询里就把他输出,输出按编号从小到大输出

思路:开数组记录每个人的对象,把查询的人先标记一下,再把对象没标记或没对象的人扔进set里输出

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>
using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
int link[1000006];
bool flag[1000006];
int a[1000006];
int main()
{
    int n,x,y,m;
    scanf("%d",&n);
    memset(link,-1,sizeof link);
    for(int i=-0; i<n; i++)
    {
        scanf("%d%d",&x,&y);
        link[x]=y;
        link[y]=x;
    }
    scanf("%d",&m);
    memset(flag,0,sizeof flag);
    for(int i=0; i<m; i++)
    {
        scanf("%d",&a[i]);
        flag[a[i]]=1;
    }
    set<int>s;
    for(int i=0; i<m; i++)
    {
        if(flag[link[a[i]]]==0||link[a[i]]==-1)
            s.insert(a[i]);
    }

    printf("%d\n",s.size());
    if(s.size()==0)
        return 0;
    set<int>::iterator it=s.begin();
    int q=0;
    for(; it!=s.end(); it++)
    {
        if(q++)
            printf(" ");
        printf("%05d",*it);
    }
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值