POJ2914 Minimum Cut(最小割)

22 篇文章 0 订阅
11 篇文章 0 订阅

Minimum Cut
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 9715 Accepted: 4085
Case Time Limit: 5000MS

Description

Given an undirected graph, in which two vertices can be connected by multiple edges, what is the size of the minimum cut of the graph? i.e. how many edges must be removed at least to disconnect the graph into two subgraphs?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (2 ≤ N ≤ 500, 0 ≤ M ≤ N × (N − 1) ⁄ 2) in one line, where N is the number of vertices. Following are M lines, each line contains M integers AB and C (0 ≤ AB < NA ≠ BC > 0), meaning that there C edges connecting vertices A and B.

Output

There is only one line for each test case, which contains the size of the minimum cut of the graph. If the graph is disconnected, print 0.

Sample Input

3 3
0 1 1
1 2 1
2 0 1
4 3
0 1 1
1 2 1
2 3 1
8 14
0 1 1
0 2 1
0 3 1
1 2 1
1 3 1
2 3 1
4 5 1
4 6 1
4 7 1
5 6 1
5 7 1
6 7 1
4 0 1
7 3 1

Sample Output

2
1
2

Source

Baidu Star 2006 Semifinal 
Wang, Ying (Originator) 
Chen, Shixi (Test cases)

———————————————————————————————————

题目的意思是给出一张图,求整体最小割

思路:模板题

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;
#define MAXN 800


int mp[MAXN][MAXN],w[MAXN],vis[MAXN],combine[MAXN];
int minC,cnt,n,m;


void Find(int &s,int &t)
{
    memset(vis,0,sizeof(vis));
    memset(w,0,sizeof(w));
    int tmp=INF;
    int q=n;
    while(q--)
    {
        int mx=-INF;
        for(int i=0; i<n; i++)
        {
            if(!vis[i]&&!combine[i]&&mx<w[i])
            {
                mx=w[i];
                tmp=i;
            }
        }
        if(t==tmp)
        {
            minC=w[t];
            return;
        }
        vis[tmp]=1;
        s=t,t=tmp;
        for(int i=0;i<n;i++)
        {
            if(!vis[i]&&!combine[i])
                w[i]+=mp[t][i];
        }
    }
    minC=w[t];
}

int mincut()
{
    int ans=INF;
    int s,t;
    memset(combine,0,sizeof(combine));
    for(int i=0; i<n-1; i++)
    {
        s=t=-1;
        Find(s,t);
        combine[t]=true;
        ans=min(ans,minC);
        for(int i=0;i<n;i++)
        {
            mp[s][i]+=mp[t][i];
            mp[i][s]+=mp[i][t];
        }
    }
    return ans;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(mp,0,sizeof(mp));
        int u,v,w;
        while(m--)
        {
            scanf("%d %d %d",&u,&v,&w);
            mp[u][v]+=w;
            mp[v][u]+=w;
        }
        printf("%d\n",mincut());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值