Hdu6130 Kolakoski(2017多校第7场)

75 篇文章 0 订阅

Kolakoski

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 249    Accepted Submission(s): 116


Problem Description
This is Kolakosiki sequence: $1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1……$. This sequence consists of $1$ and $2$, and its first term equals $1$. Besides, if you see adjacent and equal terms as one group, you will get $1,22,11,2,1,22,1,22,11,2,11,22,1……$. Count number of terms in every group, you will get the sequence itself. Now, the sequence can be uniquely determined. Please tell HazelFan its $n$th element.
 

Input
The first line contains a positive integer $T(1\leq T\leq5)$, denoting the number of test cases.
For each test case:
A single line contains a positive integer $n(1\leq n\leq10^7)$.
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
1 2
 

Source

————————————————————————————————————
题目的意思思给出一个序列,他的生成是每个数表示几个相同的连续一样的
思路:打表

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <map>
#include <set>
#include <algorithm>
#include <complex>
#include <vector>
#include <bitset>
#include <stack>
#include <queue>
#include <unordered_map>
#include <functional>

using namespace std;

int a[10000007];

int main()
{
    a[1]=1;
    a[2]=2;
    int cnt=2;
    for(int i=1; i<10000001;)
    {
        for(int j=0; j<a[cnt]; j++)
        {
            a[i+j+1]=a[i]^3;
        }
        i+=a[cnt];
        cnt++;
    }
    int T,x;
    for(scanf("%d",&T); T--;)
    {
        scanf("%d",&x);
        printf("%d\n",a[x]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值