Hdu6121 Build a tree(2017多校第7场)

Build a tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 556    Accepted Submission(s): 178


Problem Description
HazelFan wants to build a rooted tree. The tree has  n  nodes labeled  0  to  n1 , and the father of the node labeled  i  is the node labeled  i1k . HazelFan wonders the size of every subtree, and you just need to tell him the XOR value of these answers.
 

Input
The first line contains a positive integer  T(1T5) , denoting the number of test cases.
For each test case:
A single line contains two positive integers  n,k(1n,k1018) .
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
  
  
2 5 2 5 3
 

Sample Output
  
  
7 6
 

Source

————————————————————————————————————

有一棵nn个点的有根树,标号为00n-1n1ii号点的父亲是\lfloor\frac{i-1}{k}\rfloorki1号点,求所有子树大小的异或和。

这是一棵完全k叉树,考虑根的所有孩子,最多只有一个不是满k叉树,对这个孩子进行递归处理即可,剩下的可以直接算出来。k>1时只有log层,直接做就到底就好了,k=1时要特判

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <map>
#include <set>
#include <algorithm>
#include <complex>
#include <vector>
#include <bitset>
#include <stack>
#include <queue>
#include <unordered_map>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

LL n,k;
LL ans;

LL llpow(LL x, LL y)
{
    LL ans = 1;
    while(y >= 1)
    {
        if(y & 1)
        {
            ans *= x;
        }
        x *= x;
        y >>= 1;
    }
    return ans;
}

void fff(LL x)
{
    if(x < 1)
        return;
    ans ^= x;
    if(k % 2 == 0)
    {
        LL nn = x, p = 1, cs = 1;
        nn--;
        while(nn - p * k >= 0) p *= k, nn -= p, cs++;
        if(nn == 0)
        {
            return;
        }
        LL t = llpow(k, cs - 1);
        LL tt = nn / t;
        if(nn % t == 0)
        {
            if(tt % 2 != 0)
            {
                fff((x - nn - 1) / k + t);
                fff((x - nn - 1) / k);
            }
        }
        else
        {
            if(tt % 2 != 0)
            {
                fff((x - nn - 1) / k + t);
                fff((x - nn - 1) / k + nn % t);
            }
            else
            {
                fff((x - nn - 1) / k + nn % t);
                fff((x - nn - 1) / k);
            }
        }
    }
    else
    {
        LL nn = x, p = 1, cs = 1;
        nn--;
        while(nn - p * k >= 0) p *= k, nn -= p, cs++;
        if(nn == 0)
        {
            fff((x - 1) / k);
            return;
        }
        LL t = llpow(k, cs - 1);
        LL tt = nn / t;
        if(nn % t == 0)
        {
            if(tt % 2 != 0)
            {
                fff((x - nn - 1) / k + t);
            }
            else
            {
                fff((x - nn - 1) / k);
            }
        }
        else
        {
            if(tt % 2 != 0)
            {
                fff((x - nn - 1) / k);
                fff((x - nn - 1) / k + t);
                fff((x - nn - 1) / k + nn % t);
            }
            else
            {
                fff((x - nn - 1) / k + nn % t);
            }
        }
    }
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%lld %lld",&n,&k);
        if(k==1)
        {
            if(n%4==0) printf("%lld\n",n);
            else if(n%4==1) printf("1\n");
            else if(n%4==2) printf("%lld\n",n+1LL);
            else printf("0\n");
            continue;
        }
        ans = 0;
        fff(n);
        printf("%lld\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值