Hdu6140 Hybrid Crystals(2017多校第8场)

Hybrid Crystals

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 399    Accepted Submission(s): 253


Problem Description
> Kyber crystals, also called the living crystal or simply the kyber, and known as kaiburr crystals in ancient times, were rare, Force-attuned crystals that grew in nature and were found on scattered planets across the galaxy. They were used by the Jedi and the Sith in the construction of their lightsabers. As part of Jedi training, younglings were sent to the Crystal Caves of the ice planet of Ilum to mine crystals in order to construct their own lightsabers. The crystal's mix of unique lustre was called "the water of the kyber" by the Jedi. There were also larger, rarer crystals of great power and that, according to legends, were used at the heart of ancient superweapons by the Sith.
>
> — Wookieepedia

Powerful, the Kyber crystals are. Even more powerful, the Kyber crystals get combined together. Powered by the Kyber crystals, the main weapon of the Death Star is, having the firepower of thousands of Star Destroyers.

Combining Kyber crystals is not an easy task. The combination should have a specific level of energy to be stablized. Your task is to develop a Droid program to combine Kyber crystals.

Each crystal has its level of energy ( i -th crystal has an energy level of  ai ). Each crystal is attuned to a particular side of the force, either the Light or the Dark. Light crystals emit positive energies, while dark crystals emit negative energies. In particular,

* For a light-side crystal of energy level  ai , it emits  +ai  units of energy.
* For a dark-side crystal of energy level  ai , it emits  ai  units of energy.

Surprisingly, there are rare neutral crystals that can be tuned to either dark or light side. Once used, it emits either  +ai  or  ai  units of energy, depending on which side it has been tuned to.

Given  n  crystals' energy levels  ai  and types  bi  ( 1in ),  bi=N  means the  i -th crystal is a neutral one,  bi=L  means a Light one, and  bi=D  means a Dark one. The Jedi Council asked you to choose some crystals to form a larger hybrid crystal. To make sure it is stable, the final energy level (the sum of the energy emission of all chosen crystals) of the hybrid crystal must be exactly  k .

Considering the NP-Hardness of this problem, the Jedi Council puts some additional constraints to the array such that the problem is greatly simplified.

First, the Council puts a special crystal of  a1=1,b1=N .

Second, the Council has arranged the other  n1  crystals in a way that
aij=1i1aj[bj=N]+j=1i1aj[bi=Lbj=L]+j=1i1aj[bi=Dbj=D](2in).

[cond]  evaluates to  1  if  cond  holds, otherwise it evaluates to  0 .

For those who do not have the patience to read the problem statements, the problem asks you to find whether there exists a set  S{1,2,,n}  and values  si  for all  iS  such that

iSaisi=k,


where  si=1  if the  i -th crystal is a Light one,  si=1  if the  i -th crystal is a Dark one, and  si{1,1}  if the  i -th crystal is a neutral one.
 

Input
The first line of the input contains an integer  T , denoting the number of test cases.

For each test case, the first line contains two integers  n  ( 1n103 ) and  k  ( |k|106 ). 

The next line contains  n  integer  a1,a2,...,an  ( 0ai103 ).

The next line contains  n  character  b1,b2,...,bn  ( bi{L,D,N} ).
 

Output
If there exists such a subset, output "yes", otherwise output "no".
 

Sample Input
  
  
2 5 9 1 1 2 3 4 N N N N N 6 -10 1 0 1 2 3 1 N L L L L D
 

Sample Output
  
  
yes no
 

Source
 
————————————————————————————————————
题目的意思是给出n块晶石,L表示负,D表示正,N表示随便定,问取出一些能否凑成k
思路:现场题目看错了。。。以为都要取。背锅。取一部分就更简单了,首先那和很复杂的公式限定的他a的成长,使得可以凑出0到所有和的每一个数。有了这个结论后,题目就明显了:

一开始只有 a_1a1 的时候能够构成 [-1, 1][1,1] 中的所有整数.

如果一堆数能够构成 [-a, b][a,b] 中的所有整数, 这时候来了一个数 xx. 如果 xx 只能取正值的话, 如果有 x \le bxb, 那么就能够构成 [-a, b+x][a,b+x] 的所有整数.

如果 xx 只能取负值, 如果有 x \le yxy, 那么就能构成 [-a-x, b][ax,b] 的所有整数.

如果 xx 可正可负, 如果有 x \le min(x, y)xmin(x,y), 那么就能构成 [-a-x, b+x][ax,b+x] 中的所有整数.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <map>
#include <set>
#include <algorithm>
#include <vector>
#include <bitset>
#include <stack>
#include <queue>
#include <unordered_map>
#include <functional>

using namespace std;

#define LL long long
const int INF=0x3f3f3f3f;

int n,k;
int a[1009];
char ch[1009][5];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        int sum=0;
        int sum1 = 0;
        int sum2 = 0;
        for(int i=1; i<=n; i++) scanf("%d",&a[i]);
        for(int i=1; i<=n; i++)
        {
            scanf("%s",&ch[i]);
            if(ch[i][0]=='N') sum+=a[i];
            else if(ch[i][0]=='L') sum1+=a[i];
            else sum2+=a[i];
        }
        if(k <= sum + sum1 && k >= -sum - sum2)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值