PTA后缀式求值 (20分)

题目描述

我们人类习惯于书写“中缀式”,如 3 + 5 * 2 ,其值为13。 (p.s. 为什么人类习惯中缀式呢?是因为中缀式比后缀式好用么?)
而计算机更加习惯“后缀式”(也叫“逆波兰式”,Reverse Polish Notation)。上述中缀式对应的后缀式是: 3 5 2 * +
现在,请对输入的后缀式进行求值。

输入格式:

在一行中输入一个后缀式,运算数和运算符之间用空格分隔,运算数长度不超过6位,运算符仅有+ - * / 四种。

输出格式:

在一行中输出后缀式的值,保留一位小数。

输入样例:

3 5.4 2.2 * +

输出样例:

14.9

c++版

#include <bits/stdc++.h>
using namespace std;

int main()
{
	stack<double>st;
	string str;
    while(cin>>str)
    {
        if(isdigit(str[0])||str.size()>1)
			st.push(stod(str));
		else
        {
			double b = st.top();
			st.pop();
            double a = st.top();
			st.pop();
            if(str[0] == '+')
                st.push(a+b);
            else if(str[0] == '-')
                st.push(a-b);
            else if(str[0] == '*')
                st.push(a*b);
            else if(str[0] == '/')
                st.push(a/b);
        }
    }
    printf("%.1lf\n", st.top());
    return 0;
}

c语言版

#include <stdio.h>

int main(){
	char str[10];
	double st[100];
	int i=0;
	while(~scanf("%s", str)){
		if(str[1] == '\0' && (str[0] == '+'||str[0] == '-'||str[0] == '*'||str[0] == '/')){
			double num1, num2, res;
			num1 = st[--i];
			num2 = st[--i];
			switch(str[0]){
				case '+': res = num2 + num1; st[i++]=res; break;
				case '-': res = num2 - num1; st[i++]=res; break;
				case '*': res = num2 * num1; st[i++]=res; break;
				case '/': res = num2 / num1; st[i++]=res; break;
			}
		}else{
			double number;
			sscanf(str, "%lf", &number);
			st[i++]=number;
		}
	}
	printf("%.1lf", st[0]);
	return 0;
}

下面附通过记录
在这里插入图片描述

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值