题目描述
我们人类习惯于书写“中缀式”,如 3 + 5 * 2 ,其值为13。 (p.s. 为什么人类习惯中缀式呢?是因为中缀式比后缀式好用么?)
而计算机更加习惯“后缀式”(也叫“逆波兰式”,Reverse Polish Notation)。上述中缀式对应的后缀式是: 3 5 2 * +
现在,请对输入的后缀式进行求值。
输入格式:
在一行中输入一个后缀式,运算数和运算符之间用空格分隔,运算数长度不超过6位,运算符仅有+ - * / 四种。
输出格式:
在一行中输出后缀式的值,保留一位小数。
输入样例:
3 5.4 2.2 * +
输出样例:
14.9
c++版
#include <bits/stdc++.h>
using namespace std;
int main()
{
stack<double>st;
string str;
while(cin>>str)
{
if(isdigit(str[0])||str.size()>1)
st.push(stod(str));
else
{
double b = st.top();
st.pop();
double a = st.top();
st.pop();
if(str[0] == '+')
st.push(a+b);
else if(str[0] == '-')
st.push(a-b);
else if(str[0] == '*')
st.push(a*b);
else if(str[0] == '/')
st.push(a/b);
}
}
printf("%.1lf\n", st.top());
return 0;
}
c语言版
#include <stdio.h>
int main(){
char str[10];
double st[100];
int i=0;
while(~scanf("%s", str)){
if(str[1] == '\0' && (str[0] == '+'||str[0] == '-'||str[0] == '*'||str[0] == '/')){
double num1, num2, res;
num1 = st[--i];
num2 = st[--i];
switch(str[0]){
case '+': res = num2 + num1; st[i++]=res; break;
case '-': res = num2 - num1; st[i++]=res; break;
case '*': res = num2 * num1; st[i++]=res; break;
case '/': res = num2 / num1; st[i++]=res; break;
}
}else{
double number;
sscanf(str, "%lf", &number);
st[i++]=number;
}
}
printf("%.1lf", st[0]);
return 0;
}
下面附通过记录