HDU 1005 Number Sequence


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 149740    Accepted Submission(s): 36453


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
Sample Output
   
   
2 5
 

这道题目看似容易,其实还是很灵活的,首先想到的可能是递归或者是循环,但是别忘了,n的取值可是允许到100000000的,如果是一直运行下去,必然会超时。怎么办呢?

当看到每一项都是7的模,分析之后可以发现,其实所有的情况一共包含在7*7一共49种情况里面,换句话说,我们只要算出前49项,然后的第n项直接取7的模然后到对应的数组中去求就可以了,好了,贴代码:

#include<iostream>
using namespace std;
int main()
{
	int A,B;
	long int n;
	while(cin>>A>>B>>n)
	{
		bool flage=true;
		bool tag=true;
		int i;
		if(A==0&&B==0&&n==0)break;
		if(n==1||n==2)cout<<1<<endl;
		else
		{
			int *b=new int[50];
			b[1]=b[2]=1;
			for(i=3;i<=49;i++)
			{
				b[i]=(A*b[i-1]+B*b[i-2])%7;
			}
			cout<<b[n%49]<<endl;
			continue;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值