浙大数据结构习题笔记:02-线性结构4 Pop Sequence (25分)

02-线性结构4 Pop Sequence (25分)

灵感参考 《数据结构》02-线性结构4 Pop Sequence

题目

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:*

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

理解感悟

因为我之前没有搞过这种英文OJ的类型,所以真的是一脸懵逼……完全是看着分析网上大佬的分析来理解的,具体分析大佬的那篇文章写得更好

在这里我就手动罗列一个错误行输入的验证表格
例如:1 7 6 5 4 3 2

入栈数组curv[cur]出栈
111 7 6 5 4 3 2111
221 7 6 5 4 3 227NULL
32 31 7 6 5 4 3 227NULL
42 3 41 7 6 5 4 3 227NULL
52 3 4 51 7 6 5 4 3 227NULL
62 3 4 5 61 7 6 5 4 3 227NULL
72 3 4 5 6 7 FULL

类似于这段,它的死因是因为栈满了,直接break掉了,而cur自然不可能等于n+1,所以终结了

具体代码实现

#include<iostream>
#include<vector>
#include<stack>
using namespace std;
int main(){
	int m,n,k;
	cin>>m>>n>>k;
	for(int i=0;i<k;i++){
		stack<int> s;
		vector<int> v(n + 1);
        //创建栈S和数组V,其中V使用1-n+1的空间位置
		for(int j=1;j<=n;j++)
			cin>>v[j];
		int cur=1;
        //因为使用1-n+1的位置,所以cur从1开始
		for(int j=1;j<=n;j++){
			s.push(j);
			if(s.size() > m)
				break;
			while(!s.empty() && s.top()==v[cur]){
				s.pop();
				cur++;
			}
		}
		if(cur == n+1)
            //同上,如果正确的话,cur应指向数组最后一个下标(n+1)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值