A-素数环dfs

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Input
n (0 < n < 20). 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
分析:使用深搜来实现此题,深搜的是实际过程就是遍历每一种可能性知道满足边界值然后输出结果,
这个题就是你并不知道哪种序列是最终结果,就是把欢上面的每个节点填满即可,当然要进行不断地回溯寻找答案。注意标志数组的清除即可
import java.util.*;

public class Main {
    static Scanner in = new Scanner(System.in);
    static int n;
    static int[] a = new int[25];
    static int[] vis = new int[25];
    //判断素数,此题数据比较少,也可以采用预先打表的方式来做
    static int[] primelist = {0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0
    		,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1}; //注意最大和的值为38
    static boolean isPrime(int x) {
    	if(x<2)
    		return false;
    	for (int i = 2; i <= Math.sqrt(x); i++) {
			if(x%i==0)
				return false;
		}
    	return true;
    }
    static void dfs(int de) {
    	//不要忘了这是一个环,所以第一个和最后一个也要判断
    	if(de==n&&isPrime(a[1]+a[n])) {
    		for (int i = 1; i <= n-1; i++) {
				System.out.print(a[i]+" ");
			}
    		System.out.println(a[n]);
    		return;
    	}
    	//尝试每个
    	for (int i = 2; i <= n; i++) {
			if(vis[i]==0&&isPrime(a[de]+i)) {
				vis[i]=1;
				a[de+1]=i;//填充这个节点,当前层
				dfs(de+1);//填充下一个节点
				vis[i]=0;
			}
		}
    }
	public static void main(String[] args) {
		int cas=0;
		 
		while(in.hasNext()) {
			Arrays.fill(vis, 0);
			a[1]=1;vis[1]=1;
			cas++;
			n = in.nextInt();
			System.out.println("Case "+cas+":");
			dfs(1);
			System.out.println();
		}

	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值