Oil Deposits --dfs

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2
分析:很经典的一道深搜题,标志数组不一定非要单独开出来,直接在原来的数组上面进行扩展即可。另外,大多数深搜都要需要回溯(需要寻找最优或者不同的可能结果),而这个题不需要,因为我们找到连着的即可,相当于涂色。。。
上代码:
import java.util.*;

public class Main {
    static Scanner in = new Scanner(System.in);
    static int m,n;
    static char[][] ma = new char[105][105];
    //这个题加上了对角线,所以有八个方向
    static int[][] dir = {
    		{0,1},{1,0},{0,-1},{-1,0},{-1,-1},{1,1},{1,-1},{-1,1}
    }; 
    static void dfs(int x,int y) {
    	//
    	ma[x][y]='*';//标记走过
    	int tx=0,ty=0;
    	for (int i = 0; i < 8; i++) {
    		tx=x+dir[i][0];
    		ty=y+dir[i][1];
    		if(tx<0||ty<0||tx>=m||ty>=n)
    			continue;
			if(ma[tx][ty]=='@') {
				dfs(tx,ty);
			}
		}
    }
	public static void main(String[] args) {
		int cnt=0;
		while(in.hasNext()) {
			cnt=0;
			m = in.nextInt();
			n = in.nextInt();
			if(m==0&&n==0)
				break;
			String s;
			for (int i = 0; i < m; i++) {
				s=in.next();
				for (int j = 0; j < s.length(); j++) {
					ma[i][j]=s.charAt(j);
				}
			}
			for (int i = 0; i < m; i++) {
				for (int j = 0; j < n; j++) {
					if(ma[i][j]=='@') {
				      dfs(i,j);
					  cnt++	;	
					}			  
				}
			}
			System.out.println(cnt);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值