字符串排序

先输入你要输入的字符串的个数。然后换行输入该组字符串。每个字符串以回车结束,每个字符串少于一百个字符。如果在输入过程中输入的一个字符串为“stop”,也结束输入。 
然后将这输入的该组字符串按每个字符串的长度,由小到大排序,按排序结果输出字符串。 

Input

字符串的个数,以及该组字符串。每个字符串以‘\n’结束。如果输入字符串为“stop”,也结束输入.

Output

将输入的所有字符串按长度由小到大排序输出(如果有“stop”,不输出“stop”)。 
 

Sample Input

5
sky is grey
cold
very cold
stop
3
it is good enough to be proud of
good
it is quite good

Sample Output

cold
very cold
sky is grey
good
it is quite good
it is good enough to be proud of

没什么好说的,就是练习c++的多组字符串输入-==--

#include<iostream> 
#include<string>
#include<vector>
#include<algorithm>

using namespace std;
bool cmp(string a,string b){
	return a.length()<b.length();
}
int main(){
	vector<string> st;
    int n;
    
    while(cin>>n&&n){
    	cin.get();
    	st.clear();
    	string s;
		while((n-->0)&&getline(cin,s)&&s!="stop")
		     st.push_back(s);
	    sort(st.begin(),st.end(),cmp);
	    for(int i = 0;i < st.size();i++)
	       cout<<st[i]<<endl;
	    
	}
	return 0;
}

借鉴用法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值