杭电OJ 1671解题报告(字典树模板)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14925    Accepted Submission(s): 5029


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
/*
题目大意是你打电话 如果某个号码的前缀与某个号码相同 就不能被拨打(因为会打到那个与它前缀相同的号码那儿去)。如果存在这种情况 输出NO 否则输出YES
显然 这是字典树的简单运用 注意字典树内存的清理 否则会造成内存泄露!!
*/

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;


int T,N;
char PhoneNum[10001][11];


typedef struct Dictionary_Tree
{
	//int cou;
	bool flag;   //标记是否是某个单词的结尾 
	struct Dictionary_Tree *next[11];
}DictionaryTree;


DictionaryTree *Free[100005]; 
int Cou_Free;


bool Fun(int k,DictionaryTree &root)  //引用 
{
	DictionaryTree *point=&root,*newnode;
	int t;
	for(int i=0;PhoneNum[k][i]!='\0';i++)
	{
		t=PhoneNum[k][i]-'0';
		//cout<<"@@\n";
		if(point->next[t] == NULL)
		{
			newnode=(DictionaryTree*)malloc(sizeof(DictionaryTree));
			memset(newnode,0,sizeof(DictionaryTree));
			
			Free[Cou_Free++] = newnode;
			/*newnode->flag=false;
			for(int I=0;I<=10;I++)
			newnode->next[I]=NULL;*/
			
			//newnode->cou=1;
			
			//if(newnode->next[PhoneNum[k][i+1]-'0']==NULL) t=t;///
			
			if(PhoneNum[k][i+1]=='\0') //已到末尾
			{
				newnode->flag=true;
				
			} 
			
			point->next[t]=newnode;  
		}
		
		else
		{
			if(point->next[t]->flag == true || PhoneNum[k][i+1]=='\0') return false;
			//else point->next[t]->cou++;
		}
		
		point=point->next[t];   //指针跟上 
	}
	
	return true;
}


int main()
{
	while(cin>>T)
	{
		while(T--)
		{
			DictionaryTree root={false,{NULL}};
			Cou_Free=0;
			cin>>N;
			for(int i=0;i<N;i++)
			{
				scanf("%s",PhoneNum[i]);
			}
			
			bool f=true;
			
			for(int i=0;i<N;i++)
			{
				f=Fun(i,root);
				//cout<<"@@\n";
				if(f==false) {cout<<"NO\n";break;}
			}
			
			if(f==true) cout<<"YES\n";
			
			for(int i=0;i<Cou_Free;i++)
			free(Free[i]);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值