题目描述
Given a positive integer N, you shouldoutput the most right digit of N^N.
输入
The input contains several test cases. Thefirst line of the input is a single integer T which is the number of testcases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
输出
For each test case, you should output therightmost digit of N^N.
样例输入
2
3
4
样例输出
7
6
c:
#include<stdio.h>
int main()
{
int n,i,b;
int a[10][4]={{0,0,0,0},{1,1,1,1},{2,4,8,6},{3,9,7,1},{4,6,4,6},{5,5,5,5},{6,6,6,6},{7,9,3,1},{8,4,2,6},{9,1,9,1}};
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&b);
int c,d;
c=b%10;d=(b-1)%4;
if(b%10==0) printf("0\n");
else printf("%d\n",a[c][d]);
}
return 0;
}