poj 3624 Balanced Lineup

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0

此题就是输入一些数,求区间最大值与最小值的差。

此题用RMQ
dpma[i][j]:表示第j个开始,连续2^i个数的最大值;
dpmi[i][j]:表示第j个开始,连续2^i个数的最小值;
dpma[i][j]=max(dpma[i-1][j],dpma[i-1][j+(1<<(i-1))]);
(因为,从j开始的2^(i-1)个数的最大值和(j+(1<<(i-1)))开始的2^(i-1)个数的最大值比较,就产生了,从i开始的2^i个数的最大值)
dpmi[i][j]=min(dpmi[i-1][j],dpmi[i-1][j+(1<<(i-1))]);
(同上)
那查找就是
如果查u到v,想要O(1),要用尽可能长的段覆盖(重复也可以),
就可以求出

int k=(int)(log(v-u+1.0)/log(2.0));

return max(dpma[k][u],dpma[k][v-(1<< k)+1]);

return min(dpmi[k][u],dpmi[k][v-(1<< k)+1]);


#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int n;
int dpma[18][50010];
int dpmi[18][50010];
int a[50010];
void makeMa(){
  for (int i=0;i<n;++i) 
    dpma[0][i]=a[i];
  for (int i=1;(1<<i)<=n;++i)
    for (int j=0;j+(1<<i)-1<n;++j)
    dpma[i][j]=max(dpma[i-1][j],dpma[i-1][j+(1<<(i-1))]);
}
int getMa(int u,int v){
  int k=(int)(log(v-u+1.0)/log(2.0));
  return max(dpma[k][u],dpma[k][v-(1<<k)+1]);
}
void makeMi(){
  for (int i=0;i<n;++i) 
    dpmi[0][i]=a[i];
  for (int i=1;(1<<i)<=n;++i)
    for (int j=0;j+(1<<i)-1<n;++j)
    dpmi[i][j]=min(dpmi[i-1][j],dpmi[i-1][j+(1<<(i-1))]);
}
int getMi(int u,int v){
  int k=(int)(log(v-u+1.0)/log(2.0));
  return min(dpmi[k][u],dpmi[k][v-(1<<k)+1]);
}
int main(){
  int q;
  while (scanf("%d%d",&n,&q)!=EOF){
    for (int i=0;i<n;++i) scanf("%d",&a[i]);
    makeMa();
    makeMi();
    while (q--){
      int u,v;
      scanf("%d%d",&u,&v);
      u--;
      v--;
      int t1=getMa(u,v);
      int t2=getMi(u,v);
      printf("%d\n",t1-t2);
    }
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值