[HDU - 1068] Girls and Boys(二分图)

16 篇文章 0 订阅

Link:Problem - 1068

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12121    Accepted Submission(s): 5705

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

 
 
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output

 
 
5 2

Source

题意:

给你所有互相认识的人,求最多有多少人互相不认识。其实就是求最大独立集合

考虑好如何建图即可

最大独立集合 = 单边节点数 - 最大匹配数/2

Code:

#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
using namespace std;
int f[1005];
bool fr[1005][1005];
bool vis[1005];
int n,m,k,num;
int find(int x)
{
	for(int i=0;i<n;i++)
	{
		if(fr[x][i]&&!vis[i])
		{
			vis[i]=true;
			if(f[i]==-1)
			{
				f[i]=x;
				return true;
			}
			else if(find(f[i]))
			{
				f[i]=x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	while(~scanf("%d",&n))   //n表示单边节点数
	{
		memset(f,-1,sizeof(f));
		memset(fr,false,sizeof(fr));
		for(int i=0;i<n;i++)
		{
			scanf("%d: (%d)",&m,&k);  //m表示第i个节点,k表示有k个人与m认识
			for(int i=0;i<k;i++)
			{
				scanf("%d",&num);  //num表示k个与m认识的人
				fr[m][num]=true;
			}
		}
		int ans=0;
		for(int i=0;i<n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
				ans++;
		}
		printf("%d\n",n-ans/2);
	}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值