dp入门

dp入门经典——01背包问题(1)

Bone Collector

 

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 


Input
The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2  31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

const int maxn = 1e3+5;
int vol[maxn];
int val[maxn];
int dp[maxn];

int main()
{
    int T,N,V;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&N,&V);
        for(int i=0;i<N;i++)
            scanf("%d",&val[i]);
        for(int i=0;i<N;i++)
            scanf("%d",&vol[i]);

        for(int i=0;i<N;i++)
            for(int j=V;j>=vol[i];j--)
                dp[j]=max(dp[j],dp[j-vol[i]]+val[i]);

        printf("%d\n",dp[V]);

    }


    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值