eclipse中ant打包,报异常解决办法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/JordanAndyKingxx/article/details/52192583

1.第一种异常

ant build failed class not found javac1.8

这个是因为ant版本低于1.9.0的时候,跟java8不兼容,可以考虑升级ant的版本到1.9.0之上,或者将jre换成java7或java6


2.第二种异常

java.lang.UnsupportedClassVersionError: com/sun/tools/javac/Main : Unsupported major.minor version 52.0

这个时候需要 run as --> ant ... -->jre选择 jdk 1.7

当这个异常出现在Linux服务器上运行程序的时候,那说明Linux服务器上安装的jdk版本低于java8  可以考虑升级jdk到java 8

或者以jdk 1.7来编译程序,然后再在Linux服务器上运行

展开阅读全文

没有更多推荐了,返回首页