甲级PAT 1041 Be Unique(散列)

1041 Be Unique(20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题目要求: 

输入N个数,找到第一个在所有数中只出现一次的那个数

解题思路:

由于数的数量很大,查找则非常耗时。这题运用散列的思想,用牺牲空间的办法来节约时间。用数组a[i]存放按顺序依次出现的值,用数组sign[m]记录数字i出现的次数,第一次是1,第二次2。这样遍历数组a找到第一个sign[m]=1的数m。

完整代码:

#include<bits/stdc++.h>
using namespace std;

int sign[100001];
int a[100001];

int main(){
	int i,N,m;
	int num=0;
	memset(sign,0,sizeof(sign));
	cin>>N;
	for(i=0;i<N;i++){
		scanf("%d",&m);
		if(sign[m]==0){
			a[num++] = m;
		}
		sign[m]++;	
	}
	for(i=0;i<num;i++){
		m = a[i];
		if(sign[m] == 1){
			cout<<m;
			break;
		}
	}
	if(i==num){
		cout<<"None";
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值