甲级PAT 1101 Quick Sort (25 分)

1101 Quick Sort (25 分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题目要求

在快速排序中会通过主元对序列进行排序,把比主元小的放在主元的左边而把主元大的放在主元右边。题目给出一个序列,找出其中主元的个数,并按照从小到大的顺序输出所有的主元

解题思路

这里有两种方法

方法一:将给出的序列按从小到大进行排序,然后如果一个数排序后的位置和原位置相同,只需要再确保该数前面的均小于它就可以了。

方法二:找出序列每个位置对应的左边最大值和右边最小值,如果一个数是主元,那么其一定要大于左边最大值,小于右边最小值

注意

1.输出结构的最后还需输出一个回车,否则一个测试点报格式错误

2.方法二找最小值时,初始值一定要设的很大。

完整代码

方法一

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main(){
	int n,i,j,max=0,num=0;
	int a[100010],b[100010];
	vector<int> v;
	scanf("%ld",&n);
	for(i=0;i<n;i++){
		scanf("%ld",&a[i]);
		b[i]=a[i];
	}
	sort(b,b+n);
	for(i=0;i<n;i++){
		if(a[i]==b[i] && a[i] > max ){
			max=a[i];
			v.push_back(a[i]);
		}else{
		  if(a[i]>max) max=a[i];
		}
	}
	cout<<v.size()<<endl;
	for(i=0;i<v.size();i++){
		if(i==0) cout<<v[i];
		else cout<<" "<<v[i];
	} 
	cout<<endl;
	return 0;
}

方法二

#include<iostream>
using namespace std;
 
int main(){
	int i,n,leftMax[100010],rightMin[100010],a[100010],r[100010],num=0;
	scanf("%d",&n);
	for(i=0;i<n;i++) scanf("%d",&a[i]);
	leftMax[0]=0;
	rightMin[n-1]=0x3fffffff;
	for(i=1;i<n;i++) leftMax[i]=max(leftMax[i-1],a[i-1]);
	for(i=n-2;i>=0;i--) rightMin[i]=min(rightMin[i+1],a[i+1]);
	for(i=0;i<n;i++){
		if(a[i] > leftMax[i] && a[i] < rightMin[i]) r[num++]=a[i];
	}
	printf("%d\n",num);
	for(i=0;i<num;i++){
		if(i==0) printf("%d",r[i]);
		else printf(" %d",r[i]);
	}
	printf("\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值