甲级PAT 1098 Insertion or Heap Sort (25 分)(插入排序和堆排序)

1098 Insertion or Heap Sort (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题目要求 

给出一个序列以及序列进行排序的中间步骤,说明是用何种排序方式(堆排序或插入排序)以及用这种排序方式的下一步排序情况

堆排序详情:堆排序详细说明以及模板代码

插入排序详情:插入排序详细说明以及模板代码

解题思路

这个没啥好说的,先尝试堆排序,要注意堆排序事先要构建大顶堆的,然后每排序一次判断是不是和题目输入的部分过程相等,如果相等则设置isheap为true,再往后进行一次堆排序,如果不是堆排序,则进行插入排序,插入排序的下一步可能不是执行一次插入排序,可能有多次,要直到排序后的结果和部分过程不等,然后输出结果

完整代码

#include<bits/stdc++.h>
using namespace std;

int heap[110],init[110],part[110],inserta[110];
int n,isheap=false;

bool check(int sign){
	int i;
	if(sign==1){
		for(i=1;i<=n;i++){
			if(heap[i]!=part[i]) return false;
		}
		return true;
	}else{
		for(i=1;i<=n;i++){
			if(inserta[i]!=part[i]) return false;
		}
		return true;
	}
}

void downAdjust(int low,int high){
	int i=low;
	int j=2*i;
	while(j<=high){
		if(j+1<=high && heap[j+1]>heap[j]) j=j+1;
		if(heap[j]>heap[i]){
			swap(heap[j],heap[i]);
			i=j;
			j=2*i; 
		}else break;
	}
}

void createheap(){
	for(int i=n/2;i>=1;i--){
		downAdjust(i,n);
	}	
}

void heapsort(){
	int i;
	createheap();
	for(i=n;i>1;i--){
		swap(heap[i],heap[1]);
		downAdjust(1,i-1);
		if(check(1)){
			isheap=true;
			i--;
			swap(heap[i],heap[1]);
			downAdjust(1,i-1);
			break;
		}
	}
}

void insertsort(){
	int i,j,k,temp;
	for(i=2;i<=n;i++){
		temp=inserta[i];
		k=1;
		while(temp>inserta[k]) k++;
		for(j=i-1;j>=k;j--) inserta[j+1]=inserta[j];
		inserta[k]=temp; 
		if(check(2)){
			while(check(2)){
				i++;
				temp=inserta[i];
				k=1;
				while(temp>inserta[k]) k++;
				for(j=i-1;j>=k;j--) inserta[j+1]=inserta[j];
				inserta[k]=temp; 
			}
			break;
		}
	}
}

int main(){
	int i;
	cin>>n;
	for(i=1;i<=n;i++) cin>>init[i];
	for(i=1;i<=n;i++) cin>>part[i];
	memset(heap,0,sizeof(heap));
	memcpy(heap,init,(n+1)*sizeof(int));
	heapsort();
	if(isheap==false){
		memset(inserta,0,sizeof(inserta));
		memcpy(inserta,init,(n+1)*sizeof(int));
		insertsort();
		cout<<"Insertion Sort"<<endl;
		for(i=1;i<=n;i++){
			if(i!=1) cout<<" ";
			cout<<inserta[i]; 
		}
	}else{
		cout<<"Heap Sort"<<endl;
		for(i=1;i<=n;i++){
			if(i!=1) cout<<" ";
			cout<<heap[i]; 
		}
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值