甲级PAT 1064 Complete Binary Search Tree (30 分)(完全二叉查找树,BST,CBT)

1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目要求 

给出一个序列,构建完全二叉查找树,输出其层序遍历的结果

解题思路

二叉查找树中序遍历所得的结果是有序的,按照从小到大排序。

完全二叉树对于给定数量的结点其形状固定。

根据这一性质,对一个给结点数n,就可以确定其根结点在有序序列里的下标。

首先将序列a按从小到大排序,对于10个结点,可以根据序列的下标构造一棵如下图的完全二叉查找树。

可以看出,根据这棵完全二叉树很容易就能写出其层序遍历。

我们主要的任务就是找到每个结点对应的在有序序列中的下标。

利用递归实现。

对于10个结点,其根结点7,是由一个基址(因为右子树的基址和左子树的基址不同,左子树基址0,右子树基址父节点下标)+其左子树结点的个数+1得到的,

这里基址0,左子树结点个数6,所以0+6+1=7

层序遍历数组下标1的值就为level[1]=a[7]

然后需要分别对根结点7的左子树和右子树进行处理,由于层序遍历,是左子树再右子树前面,左子树根结点的层序下标为2*1,右子树根结点的下标为2*1+1。

左子树结点的个数是根据结点的个数所能构建的完全二叉树的层数height,height从1开始,1层结点总个数2^1-1,2层结点总个数2^2-1,第1层为根结点,对于n个结点的左子树的个数有两种可能情况

所以左子树的个数为min(pow(2,height-1)-1,n-pow(2,height-2))

 

参考代码

#include<bits/stdc++.h>
using namespace std;
int level[1010],a[1010];
int findleftnum(int n){
	int height=1;
	while(pow(2,height)-1<n) height++;
	if(height==1) return 0;
	else return min(pow(2,height-1)-1,n-pow(2,height-2));
}

void create(int base,int n,int index){
	if(n<=0) return;
	int left=findleftnum(n);
	int root=base+1+left;
	level[index]=a[root];
	create(base,left,2*index);
	create(root,n-left-1,2*index+1);
}

int main(){
	int n,i;
	cin>>n;
	for(i=1;i<=n;i++) cin>>a[i];
	sort(a+1,a+n+1);
	create(0,n,1);
	for(i=1;i<=n;i++){
		if(i!=1) cout<<" ";
		cout<<level[i];
	}
	return 0;
} 

 

  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值