《ACM程序设计》书中题目Z(英文缩写)

Description

When a Little White meets another Little White:

Little White A: (Surprised) !
Little White B: ?
Little White A: You Little White know "SHDC"? So unbelievable!
Little White B: You are little white! Little white is you! What is "SHDC" you are talking about?
Little White A: Wait... I mean "Super Hard-disc Drive Cooler".
Little White B: I mean "Spade Heart Diamond Club"... Duck talks with chicken -_-//
Little White A: Duck... chicken... faint!

------quote from qmd of Spade6 in CC98 forum.

Sometimes, we write the abbreviation of a name. For example IBM is the abbreviation for International Business Machines. A name usually consists of one or more words. A word begins with a capital letter ('A' - 'Z') and followed by zero or more lower-case letters ('a' - 'z'). The abbreviation for a name is the word that consists of all the first letters of the words.

Now, you are given two names and asked to decide whether their abbreviations are the same.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. And it will be followed by T consecutive test cases.

There are four lines for each case.
The first line contains an integer N (1 <= N <= 5), indicating the number of words in the first name.
The second line shows the first name.
The third line contains an integer M (1 <= M <= 5), indicating the number of words in the second name.
The fourth line shows the second name.
Each name consists of several words separated by space. Length for every word is less than 10. The first letter for each word is always capital and the rest ones are lower-case.

Output

Results should be directed to standard output. The output of each test case should be a single line. If two names' abbreviations are the same, output "SAME", otherwise output "DIFFERENT".

Sample Input

3
4
Super Harddisc Drive Cooler
4
Spade Heart Diamond Club
3
Shen Guang Hao
3
Shuai Ge Hao
3
Cai Piao Ge
4
C P C S

Sample Output

SAME
SAME
DIFFERENT

题目大意就是两串词组,比较它们缩写是否相同;

思路如下:

1.对于输入的每个单词,只储存它们的首字母;

2.储存首字母的两个字符数组放入两个字符串变量中进行对比;


程序如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        char a[15],b[15],c[15];
        string p1,p2;
        int i,j,n,x;
        cin>>n;
        for(i=0;i<n;i++)
        {
                memset(b,0,10);       //每次输入前要清空字符数组
                memset(c,0,10);
                cin>>x;
                for(j=0;j<x;j++)      //和下面的循环一样,利用字符数组逐个存储首字母
                {
                        cin>>a;
                        b[j]=a[0];
                }
                cin>>x;
                for(j=0;j<x;j++)
                {
                        cin>>a;
                        c[j]=a[0];
                }
                p1=b;
                p2=c;
                if(p1==p2)                       //比对
                        cout<<"SAME"<<endl;
                else
                        cout<<"DIFFERENT"<<endl;
        }
}


其实直接用字符串变量去做问题应该也不大,写完了才意识到@A@。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值