《ACM程序设计》书中题目R(半素数的判定)

Description

Prime Number Definition 
An integer greater than one is called a prime number if its only positive divisors (factors) are one and itself. For instance, 2, 11, 67, 89 are prime numbers but 8, 20, 27 are not.

Semi-Prime Number Definition 
An integer greater than one is called a semi-prime number if it can be decompounded to TWO prime numbers. For example, 6 is a semi-prime number but 12 is not.

Your task is just to determinate whether a given number is a semi-prime number.

Input

There are several test cases in the input. Each case contains a single integer N (2 <= N <= 1,000,000)

Output

One line with a single integer for each case. If the number is a semi-prime number, then output "Yes", otherwise "No".

Sample Input

3
4
6
12

Sample Output

No 
Yes 
Yes 
No 

题目大意是让找出100 0000以内的半素数,所谓半素数就是两个素数的积(或者说一个素数的平方);

思路如下:

1.因为数太大,如果一个一个判断很可能会超时,所以要建立半素数表利用检索找到素数;

2.100 0000以内的半素数表可以先建立50 0000以内的素数表,然后将其中的素数两两相乘得到半素数表;

3.因为set检索速度快,所以利用set存储半素数表,再利用迭代器检索;


程序如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        vector<int> v;
        set<int> s;
        set<int>::iterator p;
        int i,j,x,n;
        for(i=2;i<=500000;i++)         //建立素数表
        {
                if(i!=2&&i%2==0)
                        A:continue;
                else
                        for(j=3;j*j<=i;j+=2)
                        {
                                if(i%j==0)
                                        goto A;
                        }
                v.push_back(i);
        }
        for(i=0;i<v.size();i++)        //建立半素数表
        {
                for(j=0;j<v.size();j++)
                {
                        x=v[i]*v[j];
                        if(x<1000000)
                                s.insert(x);
                        else
                                break;
                }
        }
        while(cin>>n)
        {
                p=s.find(n);    //检索
                if(p!=s.end())
                        cout<<"Yes"<<endl;
                else
                        cout<<"No"<<endl;
        }
}
其实一开始我看这道题是懵逼的,以前没用用过建立库去检索的方法,这样解决不了超时的问题,但是这种办法对于有规律数字的检索实在是很好用,能省去大量的运行时间。

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值