《ACM程序设计》书中题目T(谁的几次方最接近它O.O。。。)

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input: The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output: For each pair B and N in the input, output A as defined above on a line by itself.

Example Input:Example Output:
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0
1
2
3
4
4
4
5
16

题目大意就是给出两个整数B和N,求一个数A,使A的N次方最接近于B;

思路如下:

1.利用pow计算出B的1/N次方,int A保存;

2.比较A和A+1哪一个和B更接近(因为浮点型转整型是保留整数位,所以不用考虑四舍五入的问题);


代码如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        double b,n;
        int a;
        while(cin>>b>>n)
        {
                if(b==0)
                        break;
                else
                {
                        a=pow(b,1/n);
                        if(b-pow(a,n)<=pow(a+1,n)-b)
                                cout<<a<<endl;
                        else
                                cout<<a+1<<endl;
                }
        }
}

只要知道pow函数就没什么难度了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值