The 7th Zhejiang Provincial Collegiate Programming Contest - G(Wu Xing)

Introduction

The Wu Xing, or the Five Movements, Five Phases or Five Steps/Stages, are chiefly an ancient mnemonic device, in many traditional Chinese fields.

The doctrine of five phases describes two cycles, a generating or creation cycle, also known as "mother-son", and an overcoming or destruction cycle, also known as "grandfather-nephew", of interactions between the phases.

Generating:

  • Wood feeds Fire;
  • Fire creates Earth (ash);
  • Earth bears Metal;
  • Metal carries Water (as in a bucket or tap, or water condenses on metal);
  • Water nourishes Wood.

Overcoming:

  • Wood parts Earth (such as roots) (or Trees can prevent soil erosion );
  • Earth absorbs (or muddies) Water (or Earth dam control the water);
  • Water quenches Fire;
  • Fire melts Metal;
  • Metal chops Wood.

Wu Xing

With the two types of interactions in the above graph, any two nodes are connected by an edge.

Problem

In a graph with N nodes, to ensure that any two nodes are connected by at least one edge, how many types of interactions are required at least? Here a type of interaction should have the following properties:

  • It can be represented as a set of directed edges in the graph.
  • For each type of interaction, there should be one and only one edge starting at each node.
  • For each type of interaction, there should be one and only one edge ending at each node.
  • The interactions are made up of cycles, i.e. starting from an arbitrary node and following the edges with the same type of interaction, you can always reach the starting node after several steps.

Input

For each test case, there's a line with an integer N (3 <= N < 1,000,000), the number of nodes in the graph.

N = 0 indicates the end of input.

Output

For each test case, output a line with the number of interactions that are required at least.

Sample Input

5
0 

Sample Output

2 
解题报告:
此题是一道变态题,说难他很难,他容易,他太容易了。如果你看到这道题就把他判为一道图论题,就开始想图论的算法,什么出度入度,什么邻接矩阵,那我可以告诉你,你估计要悲剧了。题目大意是说,用最少的环试给的几个点,任意两个点之间都有联系。这道题当中应该相当注意一点就是N (3 <= N < 1,000,000)。 1,000,000可是一个不小的数,一般的图论题中都不会见到的。。所以当看到这个的时候,你应该适当的想一下,这应该是一道推论题(说白了就是找规律,找到一个公式可以满足所有的点)。 叫我一个一个图画,我是没有那个本事,所以纯粹的找规律看来是不行的。 剩下的方法,只能好好分析题目了。
我们可以看到,他说要是任意两个点都有联系,看到这里,马上可以想到,要满足这个条件, 必须需要n*(n-1)/2条边,于是,换一种思考,该题目就可以理解为,在n*(n-1)/2条边中可以构成几个环。如果想到这里,你又开始去画点画边,那估计最后结果还是要悲剧。至少我是画不出,就算画出了也不知道到底是否是最小个数的环。 所以我们接着继续分析。。。抛开怎么连线不管, 往整体方向想,要构成一个环, n个点必须要n条边,可以理解,最终所有环所构成的边,都不会超过n*(n-1)/2条边。 所以每条边都在一个或几个环内,(其中不同的环可以共用一条边)。 所以至少有(n-1)/2个环, 如果可以整除,那么商就是答案。如果不能整除呢? 那么余下的边必定可以再组成一个环(必定的嘛)。所以如果(n-1)%2 != 0, 那么答案就等于(n-1)/2 +1;
结果就是和n/2的结果一样,如果有些同学,开玩笑地试了这个公式,恭喜你,你ac了。(踩到狗屎了,呵呵!)
代码就是那么几行,还没有题目的行数多:
#include <iostream>
using namespace std;
int main()
{
 int i,result;
 while(cin>>i && i != 0)
 {
  if((i-1) % 2 != 0)
   result = (i-1)/2+1;
  else
   result = (i-1)/2;
  cout<<result<<endl;
 }
 return 0;
}
 
感想:很遗憾,我没有在比赛中ac这道题,因为之前因为一些数字上的小问题,导致wa,以至于我放弃了这个想法。(无比懊悔中)。
希望,看了这篇文章的同学,做题时冷静分析, 坚持自己的想法,也许ac已经离你很近了,不要让他这么轻易从你手中溜走。。。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值