swjtuoj - 2089 Digits' Sum

Digits' Sum

Description


2^15= 32768 and the sum of its digits is 3 + 2 + 7 + 6 + 8 = 26.
Give you a integer N
now, what is the sum of the digits of the number 2^N ?

Input


Each case is a line, which consists a integer N(0 <= N <= 64).

Output


Print the sum of the digits of the number 2^N.

Sample input


0

15

Sample output


1

26


#include <iostream>
#include "algorithm"
#include "cstdio"
#include "cmath"
#include "cstring"
using namespace std;
int excel[70];
int len(int opp)
{
    int i, sum = 0;
    long long s = 1;
    while(opp--) s *= 2;
    while(s)
    {
        sum += s%10;
        s /= 10;
    }
    return sum;
}
int main()
{   //freopen("1.in", "r", stdin);
    int i, k;
    for(i = 1; i <= 62; i++)
        excel[i] = len(i);
    excel[0] = 1;
    excel[63] = 89;//特殊处理
    excel[64] = 88;
    while(cin>>k) cout<<excel[k]<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值