题目描述
Phone number in Berland is a sequence of n digits. Often, to make it easier to memorize the number, it is divided into groups of three digits. For example, the phone number 119733 is easier to remember as 119-733. Your task is to find for a given phone number divisions into groups of three digits.
输入
N cases,Each case the first line contains integer n (3 ≤ n ≤ 100) (n is a multiple of 3
)— amount of digits in the phone number. The second line contains n digits — the phone number to divide into groups.
输出
Output divisions of the given phone number into groups of three digits. Separate groups by single character -.
样例输入 Copy
2
6
549871
3
117
样例输出 Copy
549-871
117
#include<iostream>
using namespace std;
int main()
{
int n;
cin >> n;
while (n--)
{
int t;
string ch;
cin >> t;
cin >> ch;
for(int i=0;i<t;i++)
{
cout << ch[i];
if ((i + 1) % 3 == 0&&i!=t-1) //防止3的倍数最后会输出‘-’
cout << '-';
}
cout << endl;
}
return 0;
}