ZZULIOJ 1246: Phone numbers

题目描述

Phone number in Berland is a sequence of n digits. Often, to make it easier to memorize the number, it is divided into groups of three digits. For example, the phone number 119733 is easier to remember as 119-733. Your task is to find for a given phone number divisions into groups of three digits.

输入

N cases,Each case the first line contains integer n (3 ≤ n ≤ 100) (n is a multiple of 3

)— amount of digits in the phone number. The second line contains n digits — the phone number to divide into groups.

输出

Output divisions of the given phone number into groups of three digits. Separate groups by single character -.

样例输入 Copy

2

6

549871

3

117

样例输出 Copy

549-871

117


#include<iostream>
using namespace std;
int main()
{
    int n;
    cin >> n;
    while (n--)
    {
        int t;
        string ch;
        cin >> t;
        cin >> ch;
        for(int i=0;i<t;i++)
        {
            cout << ch[i];
            if ((i + 1) % 3 == 0&&i!=t-1) //防止3的倍数最后会输出‘-’
                cout << '-';
        }
        cout << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

KNeeg_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值