一个人的旅行Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 49192 Accepted Submission(s): 16330 Problem Description 虽然草儿是个路痴(就是在杭电待了一年多,居然还会在校园里迷路的人,汗~),但是草儿仍然很喜欢旅行,因为在旅途中 会遇见很多人(白马王子,^0^),很多事,还能丰富自己的阅历,还可以看美丽的风景……草儿想去很多地方,她想要去东京铁塔看夜景,去威尼斯看电影,去阳明山上看海芋,去纽约纯粹看雪景,去巴黎喝咖啡写信,去北京探望孟姜女……眼看寒假就快到了,这么一大段时间,可不能浪费啊,一定要给自己好好的放个假,可是也不能荒废了训练啊,所以草儿决定在要在最短的时间去一个自己想去的地方!因为草儿的家在一个小镇上,没有火车经过,所以她只能去邻近的城市坐火车(好可怜啊~)。
Input 输入数据有多组,每组的第一行是三个整数T,S和D,表示有T条路,和草儿家相邻的城市的有S个,草儿想去的地方有D个;
Output 输出草儿能去某个喜欢的城市的最短时间。
Sample Input 6 2 3 1 3 5 1 4 7 2 8 12 3 8 4 4 9 12 9 10 2 1 2 8 9 10
Sample Output 9
思路:题意不多说了,这道题,我用vector存储图,然后把0作为起点,与能到达的点建边,权值为0,然后运用 spfa算法,最后遍历想要到达的点寻求最小值,注意vector每次清空,和初始化。 |
#include <iostream>
#include <cstdio>
#include <memory.h>
#include <algorithm>
#include <queue>
using namespace std;
const int N=1110;
const int inf=INT_MAX;
struct node
{
int u,v,w;
};
vector<node>g[N];
int vis[N],d[N];
int n,m,k;
void spfa(int sx)
{
memset(vis,0,sizeof(vis));
for(int i=0; i<N; i++)
d[i]=inf;
d[sx]=0;
vis[sx]=1;
queue<int>qu;
qu.push(sx);
while(!qu.empty())
{
int u=qu.front();
qu.pop();
vis[u]=0;
int len=g[u].size();
for(int i=0; i<len; i++)
{
int v=g[u][i].v;
int w=g[u][i].w;
if(d[v]>d[u]+w)
{
d[v]=d[u]+w;
if(!vis[v])
{
qu.push(v);
vis[v]=1;
}
}
}
}
}
int main()
{
int a,b,c;
while(~scanf("%d%d%d",&n,&m,&k))
{
for(int i=0; i<N; i++)
g[i].clear();
for(int i=0; i<n; i++)
{
scanf("%d%d%d",&a,&b,&c);
node t1;
t1.u=a;
t1.v=b;
t1.w=c;
node t2;
t2.u=b;
t2.v=a;
t2.w=c;
g[a].push_back(t1);
g[b].push_back(t2);
}
for(int i=0; i<m; i++)
{
scanf("%d",&a);
node t;
t.u=0;
t.v=a;
t.w=0;
node t1;
t1.u=a;
t1.v=0;
t1.w=0;
g[0].push_back(t);
g[a].push_back(t1);
}
int ans=inf;
spfa(0);
for(int i=0; i<k; i++)
{
scanf("%d",&a);
ans=min(ans,d[a]);
}
printf("%d\n",ans);
}
return 0;
}