HDU 233 Matrix 5015【快速幂】

3 篇文章 0 订阅
3 篇文章 0 订阅

Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 … in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333… (it means a0,1 = 233,a0,2 = 2333,a0,3 = 23333…) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,…,an,0, could you tell me an,m in the 233 matrix?

Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,…,an,0(0 ≤ ai,0 < 231).

Output

For each case, output an,m mod 10000007.

Sample Input

1 1
1
2 2
0 0
3 7
23 47 16

Sample Output

234
2799
72937

Hint

这里写图片描述

题意:

题意:求矩阵anm的元素,第一行0,233,2333,23333,。。。。然后给n个元素代表第i行第一列,ai0 元素….. aij = ai-1,j+ai,j-1 ….就根据这个公式算出所有元素。然后输出anm 。

思路:

构造转移矩阵,快速幂计算即可。
转移矩阵如下图:
这里写图片描述

ac代码:

#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <functional>
using namespace std;
typedef long long ll;
/*
23
a[1]
a[2]
a[3]
3
推下一列有:
23*10+3
a[1]+23*10+3
a[2]+a[1]+23*10+3
a[3]+a[2]+a[1]+23*10+3
3
然后转移矩阵A就可以推出来了:
10 0 0 0 1
10 1 0 0 1
10 1 1 0 1
10 1 1 1 1
0  0 0 0 1
*/

const int MOD = 10000007;
ll res[15][15];
int N;

void Matmul(ll x1[15][15], ll x2[15][15])
{
    ll t[15][15] = {0};
    for (int i = 0; i < N; i++)
        for (int k = 0; k < N; k++)
            for (int j = 0; j < N; j++)
                t[i][j] = (t[i][j] + x1[i][k] * x2[k][j] % MOD) % MOD;

    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            x1[i][j] = t[i][j];
}

void Matrix(ll X[15][15], ll n)
{
    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            res[i][j] = (i == j);
    while (n)
    {
        if (n & 1)
            Matmul(res, X);
        Matmul(X, X);
        n >>= 1;
    }
}

int main()
{
    ll n, m;
    while (scanf("%lld %lld", &n, &m) != EOF)
    {
        ll a[15];
        ll A[15][15] = {0};
        N = n + 2;
        for (int i = 1; i <= n; i++)
            scanf("%lld", &a[i]);
        a[0] = 23;
        a[n + 1] = 3;
        for (int i = 0; i < N; i++)//构造矩阵
        {
            if (i != N - 1)
                A[i][0] = 10;
            for (int j = 1; j <= i; j++)
            {
                if (i != N - 1)
                    A[i][j] = 1;
            }
            A[i][N - 1] = 1;
        }
        Matrix(A, m);
        ll ans = 0;
        for (int j = 0; j < N; j++)
            ans = (ans + a[j] * res[N - 2][j] % MOD) % MOD;
        printf("%lld\n", ans % MOD);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值