【题解】- hdu A + B Again【注意十六进制的加减】

A + B Again

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90
AC代码
#include <stdio.h>
int main(void)
{
    __int64 a, b;
    while(scanf("%I64X%I64X",&a,&b) != EOF){
        if(a + b < 0){
            printf("-%I64X\n",-(a + b));
        }
        else printf("%I64X\n",a + b);
    }
    return 0;
}

批注

十六进制直接输入并计算然后输出,不用字符串去做。

因为这里最多为15位,所以用 %I64X或%I64x(x的大小写表示输入与输出十六进制字母的大小写)。

另外还要注意:16进制如果是负数是没法直接输出的,单独处理一下就好了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值