HDU 1016 Prime Ring Problem 素数环 搜索

Prime Ring Problem  素数环  HDU 1016
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42241 Accepted Submission(s): 18719

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

简单的dfs。
code:

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<vector>
#include<math.h>
using namespace std;
int n;
int cnt;
bool used[25];
int nums[25]={0};
bool is_prime(int x)
{
    if (x==2||x==1)
        return true;
    bool is=true;
    for (int i=2;i<=sqrt(x);i++)
    {
        if (x%i==0)
        {
            is=false;
            break;
        }
    }
    return is;
}
void dfs(int x)
{
    for (int i=1;i<=n;i++)
    {
        if (!used[i]&&is_prime(x+i)&&cnt!=n)
        {
            cnt++;
            nums[cnt]=i;
            used[i]=true;
            dfs(i);
            used[i]=false;
            cnt--;
        }
        else if (cnt==n&&is_prime(nums[n]+nums[1]))
        {
            for (int i=1;i<=n-1;i++)
                cout<<nums[i]<<" ";
            cout<<nums[n]<<endl;
            break;
        }

    }
}
int main()
{
    int times=0;
    while (cin>>n)
    {
        cnt=1;
        for (int i=0;i<25;i++) used[i]=false;
        times++;
        cout<<"Case "<<times<<":"<<endl;
        used[1]=true;
        nums[1]=1;
        dfs(1);
        cout<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值